Installation and Licensing
Quick Reference Guide

QR_LMS2-4b m EMB Development



LOCATING THE LICENSE NUMBER

The license number can be found in the welcome letter of your product package. It can
also be found using the IAR License Manager, available from the Help menu in your
IAR product or from the Windows Start menu. Select your license on the Product List
page and double-click to display license information. See the Licensing Guide for
details.

TROUBLESHOOTING
If you have problems with installation or licensing:
e Read the Licensing Guide.

o Read the Release notes for your IAR product, available in the Information Center
and from the installation wizard, or the Release notes for the IAR License Server
Tools available from the installation wizard.

e Sce the technical notes on the Technical Support pages on the IAR web site,
www.iar.com/support.

e Go to www.iar.com/customercare and view FAQ for answers to your questions
about licenses, product updates, evaluation versions, and registrations, or contact
IAR Customer Care, preferably with collected diagnostic information.

IAR Systems, IAR Embedded Workbench, Embedded Trust, C-Trust, [AR Connect,
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Installation and Licensing

Introduction

This guide describes how to:

Install your IAR product with a mobile or PC-locked single-user license
Install your IAR product with a network multi-user license
Install your IAR product from the command line without human interaction

Update your existing IAR product

Transfer your mobile, PC-locked or network license from one computer to another
computer or dongle.

For more information, see the Licensing Guide.

Instructions for using the IAR License Manager from the command line are located in
the product installation subdirectory \common\doc\LightLicenseManager\.

LICENSE TYPES
Your product can use one of these license types:

o Mobile license—a single-user license, locked to a dongle (hardware lock). A
dongle is a device you attach to the computer’s USB port, which allows you to
easily transfer the license to another computer by just moving the dongle.

o PC-locked license—a single-user license, locked to the computer where your
product is installed.

o Network license—a multi-user license, located on a license server and used by
multiple users on a network. The network license is locked either to the computer
where the license server runs, or to a dongle (hardware lock).

PRODUCT UPDATES

You perform an update of an IAR product on a computer where a previous version of
the same product is already installed.

An update uses the same license number as your existing product but it requires a
license renewal. You can use the Check for License Renewal option in the License
Manager to get a valid license.

Note: Without a valid Software Update Agreement (SUA), you are not entitled to
product updates and will not get new licenses when you check for license renewals.
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Note: If you are upgrading from a size-limited license for IAR Embedded Workbench,
make sure when you build your project for the first time using the new license that you
perform a Rebuild All command and rebuild all your libraries.

SYSTEM REQUIREMENTS

For system requirements for the license server computer (network licenses only), see the
Release notes for the IAR License Server Tools. For system requirements for the
computer where your IAR product is installed, see the Installation and license
activation section in the Release notes for the product.

Note: If you use the same computer as both a license server and a client computer, some
types of files that are created by both the server and client, for example diagnostics
reports, logs, and so on, will be overwritten by the other application.

NETWORK REQUIREMENTS

For network requirements for the license server computer and client computer, see
Network requirements in the Licensing Guide.

Installing products with mobile or PC-locked licenses

To install an IAR product that uses a mobile or PC-locked license, follow this procedure:

A Install your IAR product.

B Activate your temporary startup mobile or PC-locked license.

C Activate your mobile or PC-locked license for permanent use. Perform this
step when you receive notification from IAR that your permanent license is
available.

If you are evaluating a product with a mobile or PC-locked license, follow stages A and
B of this installation procedure.
A. INSTALL YOUR IAR PRODUCT

I Remove any USB dongles.

Run the installation program (autorun.exe) for your IAR product.

Click Install to start the installation wizard.
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Follow the instructions in the installation wizard and accept the license agreements
when prompted.
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Note: You can also install the product without human interaction, using the command
line interface. See Running the installer autonomously from the command line, page 8.

B. ACTIVATE YOUR TEMPORARY STARTUP LICENSE

Following installation, start your IAR product. Unless you already have a valid
activated license, a License Wizard will start.

Select If you have a license number, enter it here and type the license number found
in the welcome letter in your product package, and click Next.

If the computer where the product is installed does not have an internet connection, you
can activate your license offline, see the information in the Licensing Guide about
activating a license when offline.

Click Register to register your license on the web page that is displayed. When you
have completed the registration, click Submit Registration to submit the registration.
When you have received your verification email from IAR, click Next to continue with
the license activation.

If you have a mobile license, attach the dongle to your computer. Make sure that only
the license dongle is connected. If your dongle has not arrived yet, you can temporarily
lock your license to your computer (one computer only). When you receive your
dongle, repeat the activation, but choose to lock the license to the dongle instead.

Confirm your license details and click Next to activate the license.

At the end of the activation process, you are given a temporary startup license (or an
evaluation license). You can now start using your product.

When you have finalized your IAR product purchase, you will receive notification that
your permanent license is available.
C. ACTIVATE YOUR LICENSE FOR PERMANENT USE

When you receive notification that your permanent license is available, start the AR
License Manager for your product from the Windows Start menu.

Choose License>Check for License Renewal to start the License Wizard.

Select the license you want to activate for permanent use, and click Check selected
licenses.

The Available Renewals dialog box is displayed, listing the licenses for which there
are new licenses available. Select the license you want to activate for permanent use,
and click Install selected to install the license.

The Renewal Results are displayed. Click OK.

The license is now available for permanent use.
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Installing products with network licenses
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To install an IAR product that uses a network license, follow this procedure:

A Install the IAR License Server Tools on a server computer. (Omit this step if
the latest version of the AR License Server Tools is already installed.)

B Activate your temporary startup network license using the IAR License
Manager on the server computer.

C Activate your network license for permanent use. Perform this step when you
receive notification from IAR that your permanent license is available.

D Install your IAR product on the client computers. Repeat this step for each
client computer.

Note: To install products from IAR, you must have administrator privileges to the
system.

Note: Two network licenses for the same IAR product and package cannot coexist on
the same license server, with the later activated license overwriting the previous one.
The previous license can be reactivated on the same computer with the same locking
criteria. If you want to add more users to a network license, contact your IAR Sales
office.

A. INSTALL THE IAR LICENSE SERVER TOOLS

The IAR License Server Tools consist of two parts—the IAR License Manager and the
Sentinel RMS License Manager.

Important: Before installing the IAR License Server Tools, you must choose a suitable
computer to use for the license server. See the system requirements described in the
Release notes for the IAR License Server Tools.

Note: Your product version requires version 2.x of the IAR License Server Tools. Some
IAR Embedded Workbench products require version 1.4x or older of the IAR License
Server Tools. A version 2.x and version 1.x installation of the IAR License Server Tools
cannot coexist on the same computer.

Note: If the latest 2.x version of the IAR License Server Tools is already installed,
proceed to B. Activate your temporary startup license, page 7.

Remove any dongles.
Run the IAR License Server Tools installation program (autorun.exe).

Click Install the IAR License Server Tools. This will first install the IAR License
Manager and then immediately continue with the Sentinel RMS License Manager.
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4 TFollow the instructions provided in the installation wizards and accept the license
agreements when prompted.

5 Configure your firewall to allow inbound traffic on UDP port 5093 (if this was not
done by the server installer).
B. ACTIVATE YOUR TEMPORARY STARTUP LICENSE
I Start the IAR License Manager for License Server on the server computer.
Choose License>Activate License to start the License Wizard.

Select Online activation and click Next.
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Type your license number and click Next. You can find your license number in the
welcome letter in your product package.

If the license server computer does not have an internet connection, you can activate
your license offline, see the information in the Licensing Guide about activating a
license when offline.

5 Click Register to register your license on the web page that is displayed. When you
have completed the registration, click Submit Registration to submit the registration.
When you have received your verification email from IAR, click Next to continue with
the license activation.

Click Next to confirm that the license should be installed on the server shown.

If your network license is using a dongle, attach the dongle to your computer, and make
sure that no other dongle is connected. Click Next to continue. If your dongle has not
arrived yet, you can temporarily lock your license to the server computer. When you
receive your dongle, repeat the activation, and lock the license to the dongle instead.

8 Confirm your license details and click Next to activate the license.
9 Finish the License Wizard.

10 At the end of the activation process, you are given a temporary startup license (or an
evaluation license). You can now start using your product.

I I To view your license in the IAR License Manager, choose View>Network Licenses.
12 When you have finalized your IAR product purchase, you will receive email
notification that your permanent license is available.
C. ACTIVATE YOUR LICENSE FOR PERMANENT USE

I On the license server computer, start the IAR License Manager for License Server from
the Windows Start menu.

2 Choose License>Check for License Renewal to start the License Wizard.
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Select the license you want to activate for permanent use, and click Check selected
licenses.

The Available Renewals dialog box is displayed, listing the licenses for which there
are new licenses available. Select the license you want to activate for permanent use,
and click Install selected to install the license.

The Renewal Results are displayed. Click OK.

The license is now available for permanent use.

D. INSTALL YOUR PRODUCT ON CLIENT COMPUTERS
Before you proceed, the license server must be up and running.

Repeat these steps on each client computer:

Remove any USB dongles.

Run the installation program (autorun.exe) for your IAR product.

Click Install to start the installation of your product.

Follow the instructions provided in the installation wizard and accept the license
agreements when prompted.

When you start your product, it will find the license server and ask you to confirm it.
Click Yes. If the license server is not found automatically, see the information in the
Licensing Guide about choosing a network license server manually.

You are now finished with the installation and the licensed product can be used.

Running the installer autonomously from the command line
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It is possible to install the IAR product (not the license server tools) from the command
line, without human interaction. To do so, invoke the installer with Administrator
privileges using the options /hide_usd and /autoinstall:

setup.exe /hide_usd /autoinstall

The option /hide_usd suppresses the multiple instances selection dialog box in
InstallShield. The executable file setup.exe is located in the ew/ directory on the
installation media.

You can optionally specify an installation directory, using the full absolute path prefixed
with a forward slash (/). There cannot be any space character between /autoinstall
and the directory path:

setup.exe /hide_usd /autoinstall/D:\My Folder\IAR_Systems
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Updating products with mobile or PC-locked licenses

To update an IAR product that uses a mobile or PC-locked license, follow this
procedure:

A Install your IAR product update.

B Renew your mobile or PC-locked license.

A. INSTALL YOUR IAR PRODUCT UPDATE
I Remove any USB dongles.
Run the installation program (autorun.exe) for your IAR product.

Click Install to start the installation of your product.
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Follow the instructions provided in the installation wizard and accept the license
agreements when prompted.

B. RENEW YOUR MOBILE OR PC-LOCKED LICENSE

I Your previous license is not valid for the new version. When you start your IAR
product, you are prompted to check for license renewal. You can also check for license
renewals in the License Manager by choosing License>Check for License Renewal.

If the computer where the product is installed does not have an internet connection, you
can activate your license offline, see the information in the Licensing Guide about
activating a license when offline.

2 If an updated license is found, you will be prompted to accept it before it is installed.

The license is now renewed for the product.

Updating products with network licenses

To update an IAR product that uses a network license, follow this procedure:
A Update the IAR License Server Tools.
B Renew your network license.

C Install your IAR product update on each client computer.
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A. UPDATE THE IAR LICENSE SERVER TOOLS

Product updates for network licenses might come with an updated license server. If that
is the case, perform the steps described in 4. Install the IAR License Server Tools, page
6, on the computer where you have the current license server installed.

The version number of the IAR License Server Tools (2 . xx) must be equal to or higher
than the version number of the License Manager (2 . yy) included with your product.

Note: This will shut down the license server and make all network licenses temporarily
unavailable.
B. RENEW YOUR NETWORK LICENSE

Note: The network licenses cannot have any commuter authorization checked out when
the license is renewed.

I On the license server computer, start the IAR License Manager for License Server from
the Windows Start menu.

2 Choose License>Check for License Renewal to start the License Wizard.
Select the license you want to check for renewals, and click Check selected licenses.

If the license server computer does not have an internet connection, you can activate
your license offline, see the information in the Licensing Guide about activating a
license when offline.

4 The Available Renewals dialog box is displayed, listing the licenses for which there
are new licenses available. Select the license you want to renew, and click Install
selected to install the license.

5 The Renewal Results are displayed. Click OK.

The network license is now renewed for the updated product.

C.INSTALL PRODUCT UPDATE ON CLIENT COMPUTERS
I Remove any USB dongles.
Run the installation program (autorun. exe) for your IAR product.

Click Install to start the installation of your product.
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Follow the instructions provided in the installation wizard and accept the license
agreements when prompted.

5 Restart your IAR product or start the IAR License Manager for your product to detect
the renewed license.
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Transferring a mobile license to another computer

You can transfer a mobile license from one computer to another using a dongle.

Note: The product can only be used on the computer which has the dongle currently
attached.

To transfer your license for a IAR product from an original computer (X) to a new
computer (Y) using a mobile license, follow these steps:
A. ORIGINAL COMPUTER (X)

I Your product is already installed and activated on computer X.

B. NEW COMPUTER (Y)
I Install your product on computer Y as described in 4. Install your IAR product, page 4.
2 Move the dongle with the license from computer X to computer Y.

On computer Y, start the IAR License Manager for your IAR product from the
Windows Start menu.

4 Choose License>Activate License to activate the same license on the same dongle as
used on computer X.

You can now use your IAR product on both computers simply by moving the dongle
between them. However, the product can only be used on the computer which has the
dongle attached.

Transferring a network license locked to a dongle
You can transfer a network license locked to a dongle to another server computer.
Note: Two network licenses for the same IAR product and package cannot coexist on
the same license server, with the later activated license overwriting the previous one.
The previous license can be reactivated on the same computer with the same locking

criteria. If you want to add more users to a network license, contact your IAR Sales
office.

To transfer your network license (which is locked to a dongle) from a license server
computer (X) to another license server computer (Y), follow these steps:

A. ORIGINAL LICENSE SERVER COMPUTER (X)

I Start the IAR License Manager for License Server from the Windows Start menu.
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2 Choose View>Network Licenses and write down the license number you want to
move. You will need this number to activate your license on license server computer Y.

3 Remove the dongle that your network license is locked to.

B. NEW LICENSE SERVER COMPUTER (Y)

I Install the IAR License Server Tools. Follow the steps in A. Install the IAR License
Server Tools, page 6.

2 Connect the dongle to license server computer Y.
Start the IAR License Manager for License Server from the Windows Start menu.

4 Choose License>Activate License to activate the same license on the same dongle as
used on computer X.

You have now moved your network license to license server computer Y.

C. EACH CLIENT COMPUTER
I Start the IAR License Manager for your IAR product from the Windows Start menu.

2 Choose License>Use Network License and select the license server computer Y as
your new license server.

The client will now look for the product license at the new location.

Transferring a PC-locked license to another computer

You can transfer a PC-locked license from one computer to another, by first deactivating
the license on the original computer, and activating the license on the computer the
license has been transferred to.

Note: You can transfer a PC-locked license up to three times during a 12-month period.
To transfer your PC-locked license between an original computer (X) and a new
computer (Y), follow these steps:
A. ORIGINAL COMPUTER (X)
I Start the IAR License Manager for your IAR product from the Windows Start menu.
Choose License>Transfer License to start the License Wizard.

Select Online transfer and click Next.
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Select the license you want to transfer, and write down the license number. You will
need this number to activate your license on computer Y.
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5 Click Next to deactivate the license.

B. NEW COMPUTER (Y)
I Install your product, as described in 4. Install your IAR product, page 4.
2 Start the IAR License Manager for your IAR product from the Windows Start menu.

Choose License>Activate License to activate the same license number used on
computer X and lock it to computer Y.

The license is now available on the new computer.

Transferring a network license locked to a license server computer

You can transfer a network license locked to a license server computer to another license
server computer.

Note: Before you can transfer a network license locked to a license server computer, you
must contact your local IAR sales office or AR Customer Care team to request
permission for the transfer.

Note: Two network licenses for the same IAR product and package cannot coexist on
the same license server, with the later activated license overwriting the previous one.
The previous license can be reactivated on the same computer with the same locking
criteria. If you want to add more users to a network license, contact your IAR Sales
office.

To transfer your network license locked to a license server computer (X) to another
license server computer (Y). Follow these steps:

A. ORIGINAL COMPUTER (X)
I Start the IAR License Manager for the License Server from the Windows Start menu.
Choose License>Transfer License to start the License Wizard.

Select Online transfer and click Next.
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Select the license you want to transfer, and write down the license number. You will
need this number to activate your license on computer Y.

5 Click Next to deactivate the license.

B. NEW COMPUTER (Y)

I Install the IAR License Server Tools. Follow the steps in A. Install the IAR License
Server Tools, page 6.



Transferring a network license locked to a license server computer

2 Start the IAR License Manager for the License Server from the Windows Start menu.

Choose License>Activate License to activate the same license number used on
computer X and lock it to computer Y.

You have now transferred your network license to license server computer Y.

C. EACH CLIENT COMPUTER
I Start the IAR License Manager for your IAR product from the Windows Start menu.

2 Choose License>Use Network License and select the license server computer Y as
your new license server.
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